EQ kicked randomly - Innerspace & MQ2

Fayman

Premium Member
Joined
Jul 3, 2008
Messages
133
Reaction score
18
Points
18
I had problems with Innerspace in combination with MQ2 from the start. Temporary solutions like using version 1.15 for Win7 and 1.16 r6308 for Win10 seized to work properly since some months. So I lived with constant crashes on Win7 when logging out. Since about 3-4 MQ2-Patches it has gone completely nuts. Constant crashes while logging out was standard. So I researched and found that the "always" problematic plugin "/autologin" seemed the cause. I disabled it since then. But after the last patches this didn't helped either (whatever changed in MQ2). I read that there was an issue with Innerspace and MQ2 solved - so I updated Innerspace to the latest version - that was perhaps a fault. I simply gave up to send in bug reports - out of pure resignation.

While Innerspace network capability is completely unreliable, I switched all boxes mostly back to EQBC (1.3, Emule version) which has its own issues (1 out of 31 at logging gets wrong name "LOGIN_"). All other EQBC-Versions I tested so far are so unreliable in heavy use that I quit using them (I am talking about raid configs over 3 computer systems with 18-31 toons, they seems stable with 3-6 toons, but at a certain data flow somethings borks easily - Emules Version can handle it but still has the login-issue if about 31 toons login at once with the usual keybinding).

Now logging in simply crashes about 3 of 9 toons. Disabling MQ2 and enabling after logged in solved that part. But sometimes the system "quits" EQ2-tasks at random (!) while simply standing in the guild hall. No crash dingdong, no message for reason, simply vanished while loading missing toons (even on the second system under Win10, while loading on Win7).

Logging in with EQ (without MQ2/Innerspace): works without problems

What in gods name did change the last 3-4 patches at MQ2 - perhaps in combination of Innerspace?
Or did DGB install a check for MQ2 now to kick the tasks?

Today I need 3 complete tries on one system (9 toons) to get the box running.

Addon: I checked the hardware/software (4 different antivirus/trojan checkers, Win7-updates, NvidiaGTX-updates, kick of unnecessary tasks in the background/minimal config, hardwarechecks 24h ramtest, heattest, stabilitytest - everything was ok, like usual for a 24/7 rendering system - using of course SSD/Samsung, 24GB Ram, Nvidia680GTX, Asus Extreme MBP, 4/8-Core Intel, all watercooled and freezing -> rockstable config renders a complete week multiple tasks without problems).
 

sc0ttr0

Premium Member
Joined
Jan 22, 2014
Messages
56
Reaction score
3
Points
8
autologin has always been goofy for me. everytime a character crashes, it will auto login with the last account in the autlogin setup, every single time. anytime i have a crashed character, I have to remove autlogin from the plugin configuration, then log that session in manually.

The first login attempt always works correctly though so that's better than nothing I guess.
 

aspire2008

Iftw
Joined
Dec 19, 2008
Messages
2,091
Reaction score
4
Points
38
autologin has always been goofy for me. everytime a character crashes, it will auto login with the last account in the autlogin setup, every single time. anytime i have a crashed character, I have to remove autlogin from the plugin configuration, then log that session in manually.

The first login attempt always works correctly though so that's better than nothing I guess.



That is normal behavior because autologin detects how many eqgame.exe sessions are running so it always does n+1, chronologically down the list of account login's you have set.


For example you have 6 accounts, and you crash on your 4th account at some point. Now you have 5 eq sessions running, autologin will try to load your 6th consecutive account (your last account in the autologin.ini) even though you crashed on your 4th one in the autologin.ini list


You can still circumvent this by using the END key, and hitting END as soon as you open a new eqgame.exe, which will stop the last account or the next consecutive account from being loaded. Although if you crash on multiple accounts this can get a bit tedious especially if you have like 10+ accounts you are loading and crash on 3-4, then have to figure out which ones you crashed on and then load those manually making sure to hit the END key at each eqgame.exe execution. This is the issue I run into most for myself since I use mq2autologin to launch about 20-22 accounts.





You may want to look into the MMOLoader Launch integration, it will launch any account in any order you want, keep in mind it won't work with isboxer or wineq2.
 

htw

Developer
Joined
Aug 27, 2006
Messages
13,060
Reaction score
209
Points
63
Location
Albuquerque, NM
aspire, I haven't used it in a long time, but doesn't the EQLaunch I did still work with WinEQ2 and IS?


htw
 

htw

Developer
Joined
Aug 27, 2006
Messages
13,060
Reaction score
209
Points
63
Location
Albuquerque, NM
Did you ever use my old EQLaunch? Until I can get some code ported into MMOLoader (it's really just the time involved), you could try this if you want, up to you. It requires .net 4.7.2 and vc++ redist x86 (2015 or 2017, same thing).


htw
 

Attachments

zoopa

Lifetime Member
Joined
Aug 29, 2012
Messages
70
Reaction score
3
Points
8
Location
Australia
You should be able to solve the logging in wrong session thing by setting
Code:
[Settings]
UseStationNamesInsteadOfSessions=1
This will then use the station name that should still be on the eqgame.exe process when it relaunches (assuming you're using virtual client.ini for each process)