MMOBugs MQ2 For EQMac PC Client - Beta Release

Fry

Fry Guy
Joined
Jan 31, 2005
Messages
11,242
Reaction score
70
Points
48
Location
Australia
Website
www.mmobugs.com
MMOBugs MacroQuest2 for EverQuest: EQMac PC Client

MMOLoader will NOT check for updates if EverQuest is running. This includes if you start MMOLoader after EQ is already running. To ensure you always have the latest updates, run MMOLoader or 'Check for Updates' from the tray icon, BEFORE you start EverQuest.

Please do not share your MMOBugs username information or MMOBugs Compile with others or your account subscription will be removed!

Basic Installation Instructions:

  1. Download MMOBugs Full Installer
  2. Run the downloaded file, and properly select your installation directory.
  3. Run MMOLoader.exe and apply appropriate updates.

Download Links:


Known Issues:

  • None

Perks of Playing on EQMac PC Client Server:

  • 100% Free To Play.
  • Game stuck in early POP era.
  • Very friendly community.


Downfalls of Playing on EQMac PC Client Server:
  • More difficult to initially set up.
  • Limited player base.
  • Mouse stuck inside window (can be released with hotkey combo Ctrl-Alt-R)


Features of MQ2 for EQMac PC Client:
  • Added Buff Timers.
  • Fixed Bazaar Search Window.
  • Stands Character When Casting Spell Automatically.
  • PC client does not need to be at c:\EQMac if MQ2EQBugFix loaded and wsock32.dll deleted.
  • Camp Without Sitting.
  • Fully Functional Map Window Like Live.
  • Right Click Gems SpellMem.

How To Set Up PC Client To Play On EQMac Server Guide
 
Last edited by a moderator:

Fry

Fry Guy
Joined
Jan 31, 2005
Messages
11,242
Reaction score
70
Points
48
Location
Australia
Website
www.mmobugs.com
Little more information.

Here is instructions on How To Play On EQMac Server on PC.

The EQMac server is an official SOE server which is using code from early PoP era. You normally would need an Apple computer to connect to the server, but people have hacked together a PC client that works (see above link).

This MQ2 version is for the PC client for the EQMac server, not the apple client.

MMOBugs MQ2 version is still in beta testing period. Work to get MQ2MoveUtils/MQ2Cast/MQ2Melee still needs to be done to help with macroing on server.

Cool features in this version of MQ2 is MQ2MapWnd which is a ported version of the live servers map window. You can use this, with MQ2Map to see PC and NPC's on map just like live server, along with targeting, zooming, ect.

Other new features include MQ2SpellMenu. This plugin will give you a right click spell mem system just like live servers, so you don't have to mem spells through your spell book.

Major props to EqMule for the work he has put into this. You would not believe the amount of time he has spent porting over the basics of MQ2 along with coding up Map/SpellMem system.

We will not be publishing active hacks for this server. We would like to keep MQ2 usage low key and have as minimal impact on the player base as possible.

Please use this thread for bugs, suggestions and ideas.

Thanks.
 

Yoda007

Lifetimer
Joined
May 7, 2006
Messages
907
Reaction score
0
Points
16
Location
Australia
Major props to EqMule for the work he has put into this. You would not believe the amount of time he has spent porting over the basics of MQ2 along with coding up Map/SpellMem system.

We will not be publishing active hacks for this server. We would like to keep MQ2 usage low key and have as minimal impact on the player base as possible.
Well done to the MMOBugs team, and props to EqMule.

I really hope people do not in turn re-write or write destructive active hacks for this server. It probably only has a playerbase of ~800-1000 people I would guess. Active hacks would just bring far too much heat to the MQ2 community.
 

Yoda007

Lifetimer
Joined
May 7, 2006
Messages
907
Reaction score
0
Points
16
Location
Australia
I don't like to double post, but am going to continually edit this post with things I find, it may just help one more person.

Cool features added with the compile (which are not noted):

No longer need to push stand prior to casting, camping, moving forwards etc
Buff timers added
Bazaar fixed

Show a percentage of your experience down to two decimal places:
Code:
/echo ${Me.PctExp}
Removed the colour coded PC names - everyone was red to me - you need to edit macroquest.ini and change the following
Code:
[Caption Colors]
[COLOR="Red"][B]PC=OFF[/B][/COLOR]
PC-Color=ff0000
[COLOR="Red"][B]PCCon=OFF[/B][/COLOR]
 
Last edited:

Ladon

Lifetimer
Joined
May 12, 2007
Messages
158
Reaction score
0
Points
16
[*]Mouse stuck inside window (can be released with hotkey combo Ctrl-Alt-R)
Are there any members on this forum that could conceivably write a plugin for this release so that we don't have to hit Ctrl+Alt+R? I have a G key on my keyboard assigned to do it but it's sort of annoying to switch between more than two characters. ;)
 

Savate

New member
Joined
Jul 20, 2011
Messages
67
Reaction score
0
Points
0
If only mq2 worked on macs, looks like time to dual boot windows!

Quick question will macro funtions like on mq2 for live work on EQmac? Tradeskills suck and would be awesome to be able to make it easier
 

eqmule

Developer
Joined
Jul 20, 2006
Messages
342
Reaction score
1
Points
0
I dont know which macros work, I only tried fish.mac and that worked fine. Im looking forward to people reporting on what macros works and which doesn't so we can fix it and release updates.
 
Last edited:

Savate

New member
Joined
Jul 20, 2011
Messages
67
Reaction score
0
Points
0
When ever I right click on the mmoloader Icon down next to the clock I get this pop up

"Access violation at address 004C2FFE in module 'MMOLoader.exe' Read of address 20202028."
 
Last edited:

Yoda007

Lifetimer
Joined
May 7, 2006
Messages
907
Reaction score
0
Points
16
Location
Australia
REQUEST:

Is it possible to create a plugin which adds some form of logging for EQ/MQ2 crashes? As the titanium client provides zero logging, it makes troubleshooting very hard!!
 

Savate

New member
Joined
Jul 20, 2011
Messages
67
Reaction score
0
Points
0
Had some trouble getting it to load just kept crashing me so loaded EQ first then MQ2 sometimes it work sometimes it crashes tried it with unloading plugins 1 by one just seem to be random

edit: tried using /keypress open_inv_bags from pack.ini CTD every time

edit: anyone know how hard it would be to get mq2fps working with this? eqmac on PC client works so much better when I use dxtory to limit the FPS but also causes crashes as well
 
Last edited:

htw

Developer
Joined
Aug 27, 2006
Messages
12,868
Reaction score
38
Points
48
Location
Albuquerque, NM
I put up MQ2FPS. Right-click loader tray icon, check for updates.

htw
 

Yoda007

Lifetimer
Joined
May 7, 2006
Messages
907
Reaction score
0
Points
16
Location
Australia
I am having problems with MQ2EQBugFix

Whenever I use the bazaar search window, it will crash EQ, when you search for something.

Start without BugFix loaded and bazaar lets you search, but has the usual problems the PC hack has.
 

eqmule

Developer
Joined
Jul 20, 2006
Messages
342
Reaction score
1
Points
0
mq2eqbugfix only has one detour in it and its one that deals with calculating the correct checksum for the exe.

It does nothing besides that, and absoulutely should not interfere with the bazaarfix, which is just a detour bool HandleBazaarMsg_Hook(PBYTE packet) located in the mq2spellmenu plugin, maybe it should be in mq2bugfix plugin, but I haven't moved it there yet, so that cant be it, maybe you have some other plugin loaded like mq2bzsrch (which I haven't fixed yet) loaded?
 

htw

Developer
Joined
Aug 27, 2006
Messages
12,868
Reaction score
38
Points
48
Location
Albuquerque, NM
Thanks mrwizeman. Pushed update 6 Aug 2013. All please update via mmoloader, and allow it to remove MQ2BzSrch as shown.

htw
 

Yoda007

Lifetimer
Joined
May 7, 2006
Messages
907
Reaction score
0
Points
16
Location
Australia
maybe you have some other plugin loaded like mq2bzsrch (which I haven't fixed yet) loaded?
Thanks mrwizeman & HTW.

I assume this was it, even though I had selected in the plugin config not to load anything other then what I mentioned.

Oh well, it's working again now :cool:
 

Fry

Fry Guy
Joined
Jan 31, 2005
Messages
11,242
Reaction score
70
Points
48
Location
Australia
Website
www.mmobugs.com
any word on functioning macro's/plugins yet?
A fix was done today for itemnotify and finditem for items in inventory, it just needs to be released, it should be done soon. First priority is getting everything done for macroing tradeskills, once that is done MQ2MoveUtils and MQ2Twist are big priority's. Once that is finish, I think the players should be able to start making some decent macros for the server.

It's just going to take a little time.
 

eqmacjunkie

New member
Joined
Aug 7, 2013
Messages
21
Reaction score
0
Points
0
Awesome keep up the good work. Can't wait for moveutils.cast.melee :)
 

Makkli

New member
Joined
Aug 9, 2013
Messages
12
Reaction score
0
Points
0
Big Thanks to eqmule and the team who put this together. I re-subscribed just for this project. Thank you also for your commitment to keep this project about enhancements over active hacks. Thank you for making this marvelous server more accessible to me as a PC user. I'm loving it.

That being said.... I can only get the spell menu to work on my desktop and not my laptop. I confirmed the plugin being loaded, tested on a brand new no INIs, default UI toon. On the laptop a tiny square appears when I right click the empty gem which remains until I click again. Anything in particular I should look for to troubleshoot?

Also, is it possible or are there plans to duplicate spellset functionality?

BTW, did I mention Thank You?!
 

eqmule

Developer
Joined
Jul 20, 2006
Messages
342
Reaction score
1
Points
0
Yes I have plans to activate the spellset button so it acts exactly as on live servers.

Also about the empty spell menu, do you have spells in the spell book? On a new char with no spells there won't be a spell menu, also right now I only update the menu on first entering the game so if u scribe a new spell in the spell book it won't show up on the spell menu until you camp out/in. I will address that issue later.

About macros, today I checked in /combine ,

NOTE: This is an old server, this was 10 years before /useitem
you absolutely MUST have bags open for macros that deals with picking up items from them to work.

This means that you can now do tradesskill macros.
Use /itemnotify ${FindItem[=Rat Meat].InvSlot} leftmouseup
To pick it up then place in the spit with spices and you can
Do a /combine Spit
Or /combine pack 1 (assuming your spit is in bagslot 1)
/combine enviro would click the combine button if u have a worldcontainer open instead of a spit you carry around.

The only thing I haven't tried is how to put the rat meat which is on the cursor
Into the spit/enviro. Ill be posting a solution shortly unless someone beats me to it.
 
Last edited: