EQBCS Problem

Xeniaz

MQ2 Guru
Joined
Dec 7, 2006
Messages
424
Reaction score
2
Points
18
Not sure the exact cause, but I'm using EQBC along with NetBots and NetHeals.
I am hosting the EQBCS on the same computer, and use the launcher to start it. Seems to be more common if there are more players on box chat. I typically have 6-12 people on at any given time. The problem is the server seeming to not respond to the clients. At times it seems like the server is lagging and will send stuff, such as a simple /bc hello, but minutes after it was typed. When using modbot to control my group, it's not good when the server crashes. If anyone else has a similar issue, or perhaps knows how I can resolve this problem, I'd appreciate ideas / input.
 

JimJohnson

Forum Jackass
Joined
Jul 12, 2006
Messages
8,528
Reaction score
10
Points
38
I do remember people having issues with Modbot in the past with eqbc. I though the fixes got put into our eqbcs. You running all 6 toons on the pc with the server running?

I would run 40 accounts on a single server and never had more then half a second delay in commands thats including when issuing /bcaa //saysomething.

I did have some of the accounts time out now and again but never crashed. The time outs were related to my wireless I think not sure. Vista 64 with up time of almost 4 months before I took it down to reformat.
 

Vesryn

Sometimes knowledgeable
Joined
Aug 31, 2006
Messages
290
Reaction score
0
Points
16
Location
Fairbanks, Alaska
Its not just Modbot, I've been going through phases where it wont stay up with more than 2 people in it, and other times it can hold 12+. I don't use modbots, but I do have netbots and netheal loaded.
 

JimJohnson

Forum Jackass
Joined
Jul 12, 2006
Messages
8,528
Reaction score
10
Points
38
wireless? multi computer set up? Give us more to go on with your set ups. So we can try to reproduce the issues.
 

Vesryn

Sometimes knowledgeable
Joined
Aug 31, 2006
Messages
290
Reaction score
0
Points
16
Location
Fairbanks, Alaska
Wired connection to the router, only one computer lately. I've never had it stop responding until probably two compiles ago, but I haven't seen any commonality between the drops other than they tend to be in the evening. I have no processes running at that time like virusscan or whatnot.
 

JimJohnson

Forum Jackass
Joined
Jul 12, 2006
Messages
8,528
Reaction score
10
Points
38
Wired connection to the router, only one computer lately. I've never had it stop responding until probably two compiles ago, but I haven't seen any commonality between the drops other than they tend to be in the evening. I have no processes running at that time like virusscan or whatnot.
When they drop are they dropping from your EQBC server? Server on the same pc you are running 12 on?
 

Vesryn

Sometimes knowledgeable
Joined
Aug 31, 2006
Messages
290
Reaction score
0
Points
16
Location
Fairbanks, Alaska
When they drop are they dropping from your EQBC server? Server on the same pc you are running 12 on?
I generally run 9 on mine, and occasionally have a friend who logs in from another state with his. When the BC drops the whole server stops responding, get the message in window about no response, and I have to completely close the eqbcs window and restart it through mmoloader to get it running again.

Also, if I connect to his, its basically the same situation his will crash too just like mine.
 

JimJohnson

Forum Jackass
Joined
Jul 12, 2006
Messages
8,528
Reaction score
10
Points
38
Ill have to set mine back up. I never ran EQBCS from a pc that was actually logged into game. I always ran it on my bitch dual core 3.0 Pentium D.
 

Vesryn

Sometimes knowledgeable
Joined
Aug 31, 2006
Messages
290
Reaction score
0
Points
16
Location
Fairbanks, Alaska
I've always ran it from a computer that was in game, but I can hook up my laptop and run it, and try it that way too.
 

gayknight

Member
Joined
Dec 9, 2007
Messages
204
Reaction score
0
Points
16
Location
St Louis Mo
Vesryn Tell me if that solves your trouble. I have very seldom random EQBC failures. I do have a few though here and there... but I get lag sometimes. Will have anywhere from 4 to 8 on three comps and have ECBC running on one of the computers with 2 instances of EQ on it too. Or if I exodus or zone sometimes I have to close and restart EQBC and reconnect everyone.
 

htw

Developer
Joined
Aug 27, 2006
Messages
13,075
Reaction score
237
Points
63
Location
Albuquerque, NM
MQ2Netbots and/or MQ2Netheal have been known to cause weirdness in the past like this. There are old threads about it on mq2 official forums somewhere, from what I recall. I don't think anyone actually ever really tracked down why it does it.

Like JJ says though, always seems to work better with server running on different system.

Maybe something with the way connections are done, not really sure. I don't have accounts like that (and set up for macroing) that would allow me to test out any theories.

htw
 

Xeniaz

MQ2 Guru
Joined
Dec 7, 2006
Messages
424
Reaction score
2
Points
18
My system is using a wired connection, and the load on the server varies. I have noticed that the only time eqbc ever crashed for me was when I had other people connected to the server from outside my LAN. Also, it seems that the crashes only occured, when two or more people from outside the LAN were connected to the server.
 

JimJohnson

Forum Jackass
Joined
Jul 12, 2006
Messages
8,528
Reaction score
10
Points
38
My system is using a wired connection, and the load on the server varies. I have noticed that the only time eqbc ever crashed for me was when I had other people connected to the server from outside my LAN. Also, it seems that the crashes only occured, when two or more people from outside the LAN were connected to the server.
Are you running the EQBCS on a pc that is running instances of EQ?
 

Xeniaz

MQ2 Guru
Joined
Dec 7, 2006
Messages
424
Reaction score
2
Points
18
Are you running the EQBCS on a pc that is running instances of EQ?
Yes, this system is often running 1-5 instances of EQ. No problem with local only, but has problems when other people connect to it from outside. I do know that one of the other people that use BC has a not so great DSL connection, and is usually connecting to my server with 6-8 additional characters. Max load on the server at any given time is no greater than 20.
 

JimJohnson

Forum Jackass
Joined
Jul 12, 2006
Messages
8,528
Reaction score
10
Points
38
Personal theory is the server is lagging due to the eq accounts eating up system resources as they probably take priority to EQBCS. Try running it on a system you are not running EQ accounts on. then it can have full resources to host 10+ accounts
 

Xeniaz

MQ2 Guru
Joined
Dec 7, 2006
Messages
424
Reaction score
2
Points
18
I don't believe it to be a resource issue in this situation. With those instances of EQ loaded, I'm only using about a third of my system resources, not to mention that all of the other services I have active on this system are performing without any flaws or drop in speed. This is a well built, well configured computer. Also, I do not have another computer available atm to run EQBCS on.
 

htw

Developer
Joined
Aug 27, 2006
Messages
13,075
Reaction score
237
Points
63
Location
Albuquerque, NM
I don't believe it to be a resource issue in this situation. With those instances of EQ loaded, I'm only using about a third of my system resources, not to mention that all of the other services I have active on this system are performing without any flaws or drop in speed. This is a well built, well configured computer. Also, I do not have another computer available atm to run EQBCS on.
Umm.. that's not the kind of "resources" he meant. ;)

htw
 

JimJohnson

Forum Jackass
Joined
Jul 12, 2006
Messages
8,528
Reaction score
10
Points
38
I don't believe it to be a resource issue in this situation. With those instances of EQ loaded, I'm only using about a third of my system resources, not to mention that all of the other services I have active on this system are performing without any flaws or drop in speed. This is a well built, well configured computer. Also, I do not have another computer available atm to run EQBCS on.
In next few days after my network is reconfigured if you want to just test it and try to crash my eqbc server i will set it up and forward the ports so you can log in and try it on a pc that is not running EQBC.

You can try running EQBC as a service. See if that fixes your issue.

I didnt use modbot but I ran eqbcs on a wireless connection that handled 40 accounts running over 40 plugins that included MQ2NetBots MQ2NetHeals. I did now and again have 1-4 guys drop from server but it never crashed.

Only 2 things I did different

Run as a service
Run on a pc without EQ loaded on it
 

gayknight

Member
Joined
Dec 9, 2007
Messages
204
Reaction score
0
Points
16
Location
St Louis Mo
Define runa s a service?

I just loaded it up and click it. IS there something I am missing or not grasping? Please explain JJ.
 

JimJohnson

Forum Jackass
Joined
Jul 12, 2006
Messages
8,528
Reaction score
10
Points
38
you have to find the thread on this page as running it as a service. As a service it has higher priority for traffic and it automatically starts on start up. You never see the server window