Release MMOLoader Launch Integration

htw

Developer
Joined
Aug 27, 2006
Messages
13,075
Reaction score
237
Points
63
Location
Albuquerque, NM
Ok, I have finally finished it up enough for those interested to beta test it. It's in live version, and you will notice a new tray icon for it.

htw
 

Zero0003

The One Who Sees All!
Joined
Jul 25, 2006
Messages
847
Reaction score
7
Points
18
Any chance on some insight on how to use it? Did the update I see the icon but can't do anything with it. Can't right click it or do anything with it
 

Renji

Developer
Joined
Jan 11, 2014
Messages
23
Reaction score
4
Points
3
I'm not sure if I'm doing something wrong, but my MMOLoader won't even let me log in to my account. I even changed my password on the forum to try to refresh it, and it doesn't accept it.
 

htw

Developer
Joined
Aug 27, 2006
Messages
13,075
Reaction score
237
Points
63
Location
Albuquerque, NM
That part didn't change at all, and I am testing fine with multiple systems (and can see on server the same from others). Maybe your firewall decided to block it or something? What error are you getting when logging in?

As far as how to use, it should have grabbed current MMOAL.dll and MMOLoader.dll and MMOLoader.exe, and of course would need live dist and MQ2AutoLogin.ini at startup.

htw
 

Zero0003

The One Who Sees All!
Joined
Jul 25, 2006
Messages
847
Reaction score
7
Points
18
Can you give me a little more info on this htw?

This is what I have tried.

Deleted myt autologin.ini file. Did a update
Grabbed the new one which has the changeme info. I put my login and pw in for 3 accounts and the server.

I do see I have the mmoai.dll

Closed the mmoloader and reopened it. I see the icon on the bottom and right click and it does nothing.

is something supposed to happen or what should I be expecting?
 

Renji

Developer
Joined
Jan 11, 2014
Messages
23
Reaction score
4
Points
3
I wasn't receiving an error, it just kept prompting me for my password. Like I said, I even changed the password to test, and it didn't work. Upon further inspection, some of the files were blocked by my antivirus though. Strange again cause I scanned them myself and nothing found, and TotalVirus found nothing too lol... so I'll get those unblocked and try again.
 

htw

Developer
Joined
Aug 27, 2006
Messages
13,075
Reaction score
237
Points
63
Location
Albuquerque, NM
Zero, do me favor and try this, and if it enables it, I will get it corrected (I think it's causing an exception on empty option entry):

1) Close down mmoloader
2) Edit your mq2autologin.ini and
a) Add this under [Settings] if it doesn't exist:
[Settings]
UseMQ2Login=1
b) Add this section and options to start with, if they don't exist:
[Profiles]
DefaultEQPath=D:\Example_Where_Your_EQ_Is\Sony\EverQuest
NumProfiles=0
3) Save the ini
4) Start mmoloader, and see if you can right-click the icon

Also keep in mind the edit icon in add entries (looks like a little pencil) is pretty small. You need to get out of edit mode before you close the editor down, or it won't update the field you are actively editing (and not commited changes). Easiest way is after adding your last entry in the editor, click in some other row and you'll see the little pencil shown on left of your last edit row is gone.

At any rate, if the changes above work, I will get that corrected. Thanks for your feedback, hard to think about checking every case!

htw
 

Zero0003

The One Who Sees All!
Joined
Jul 25, 2006
Messages
847
Reaction score
7
Points
18
That worked.

Default EQ location didn't work on the INI but I just set that as soon as I loaded up the Config
 

htw

Developer
Joined
Aug 27, 2006
Messages
13,075
Reaction score
237
Points
63
Location
Albuquerque, NM
ssmokie: It lets you integrate with the MQ2AutoLogin plugin to start up accounts via menu.

zero: Updated to fix that issue, along with some sanity checks on ini that doesn't exist or doesn't have basic entries.

htw
 

KingArthur

AutoBots
Joined
Dec 15, 2009
Messages
525
Reaction score
26
Points
28
Best news in 2018 so far lol, especially for heavy boxer! Hate to remember so many accounts and pws. Thank you htw!!

Sending from my iPhone, by Tapatalk Pro
 
Last edited:
  • Like
Reactions: EQDAB

Zero0003

The One Who Sees All!
Joined
Jul 25, 2006
Messages
847
Reaction score
7
Points
18
Been playing with this for the last few hours. This is so awesome. Thank You for doing this.
 
  • Like
Reactions: EQDAB

Hopeless

New member
Joined
Nov 16, 2007
Messages
715
Reaction score
0
Points
0
Launch group seems not working for me.
I have to launch each session to fire up EQ.

anything I missed?
 

htw

Developer
Joined
Aug 27, 2006
Messages
13,075
Reaction score
237
Points
63
Location
Albuquerque, NM
Launch group seems not working for me.
I have to launch each session to fire up EQ.

anything I missed?
Make sure you have latest loader (4.3.0.2 as of now).

Verify in your MQ2AutoLogin.ini that it has the correct IniLocation, full path.

E.g., if your MQ2 is in D:\MacroQuest2, under [Settings], it would be:
IniLocation=D:\MacroQuest2\MQ2AutoLogin.ini

htw
 

aspire2008

Iftw
Joined
Dec 19, 2008
Messages
2,091
Reaction score
6
Points
38
Looking forward to testing this out! Especially the profiles, as I plan to just start using one mq2 directory across all computers, so the profiles is going to be nice!


Currently, I have a symbolic link to my main computer for some mq2 files, with this change in allowing Profiles for mq2autologin, I should be able to remove the symbolic link for the ini files and run off 1 mq2 folder across the network. Although I'm not sure what kinda bandwidth mq2 uses up when running a single directory off the network.
 
Last edited:

Hopeless

New member
Joined
Nov 16, 2007
Messages
715
Reaction score
0
Points
0
Launch group seems not working for me.
I have to launch each session to fire up EQ.

anything I missed?
Make sure you have latest loader (4.3.0.2 as of now).

Verify in your MQ2AutoLogin.ini that it has the correct IniLocation, full path.

E.g., if your MQ2 is in D:\MacroQuest2, under [Settings], it would be:
IniLocation=D:\MacroQuest2\MQ2AutoLogin.ini

htw

Got chance to test before server down.
Group Launch is working with new Loader!

This is excellent, before I get another dbg ban. lol

Thanks,
HL
 

Zero0003

The One Who Sees All!
Joined
Jul 25, 2006
Messages
847
Reaction score
7
Points
18
HTW,

Any limitations on how many profiles that are displayed?

I created 6 profiles, and right clicking the icon for the session manager I only have 3.

Anyway to increase that?
 

htw

Developer
Joined
Aug 27, 2006
Messages
13,075
Reaction score
237
Points
63
Location
Albuquerque, NM
Thought I did 32, but I am old and could have put '3'. LOL... I will take a look when I get home, thanks Z!

htw
 

aspire2008

Iftw
Joined
Dec 19, 2008
Messages
2,091
Reaction score
6
Points
38
Is it possible to create a hook for WinEQ2 users?

The current autologin (I guess we can call this the OLD one now) setup does it I'm not sure how hard it would be for Launch though.